kubernetes常见问题

Posted by 梁远鹏 on 2022-01-18 | 阅读 |,阅读约 1 分钟

TOC

声明

本文会持续的更新,将在使用kubernetes过程中遇到的问题都收集起来.欢迎投稿加入你遇到的问题.

跨版本升级

service-account-issuer is a required flag, –service-account-signing-key-file and –service-account-issuer are required flags

版本v1.19.16升级到v1.23.x,二进制kube-apiserver升级后启动失败,提示service-account-issuer is a required flag, --service-account-signing-key-file and --service-account-issuer are required flags,原因就是在新版本中添加了新参数而旧版本没有这个参数.

only zero is allowed

版本v1.19.16升级到v1.23.x,二进制kube-apiserver升级后启动失败,

E0118 00:40:00.935698    8504 run.go:120] "command failed" err="invalid port value 8080: only zero is allowed"

参数--insecure-port只允许设置为0.

这个还没注意到更新点,如果希望使用非tls端口要怎么做呢?

Volume挂载问题

configmap内容更新后,在pod中对应文件的修改时间没有变化

这与configmap的更新机制有关

温馨提示

本文持续更新

微信公众号

扫描下面的二维码关注我们的微信公众号,第一时间查看最新内容。同时也可以关注我的Github,看看我都在了解什么技术,在页面底部可以找到我的Github。

wechat-account-qrcode